Autonomous Tests Timing Out

Incident Report for Applitools Status

Resolved

The issue has been resolved - all Autonomous tests are now running as expected.
Posted Mar 17, 2026 - 23:45 UTC

Monitoring

We have reverted Autonomous back to a prior working version, which should resolve the test failures.
We are continuing to monitor to ensure that all tests are completing as expected.
Posted Mar 17, 2026 - 22:35 UTC

Investigating

We are investigating reports of test timeouts in Autonomus that may be preventing successful test execution. We will provide an update when we have determined a root cause.
Posted Mar 17, 2026 - 20:39 UTC
This incident affected: Autonomous.