Autonomous Interactive Browser is not functioning as expected

Incident Report for Applitools Status

Resolved

We have identified the root-cause of the issue and resolved it. Interactive browser is now fully operational.
Posted May 11, 2026 - 15:46 UTC

Update

We are continuing to investigate this issue.
Posted May 11, 2026 - 15:45 UTC

Investigating

We are currently investigating an issue with the interactive browser in Autonomus. Users may not be able to connect.
We are currently investigating the issue and will provide an update as soon as possible.
Posted May 11, 2026 - 14:57 UTC
This incident affected: Autonomous.