Eyes & Autonomous Public Outage

Incident Report for Applitools Status

Resolved

All clouds are fully operational.
Posted Oct 07, 2025 - 17:20 UTC

Identified

Both Eyes and Autonomous public cloud services are currently unavailable due to an Azure Storage downtime affecting our infrastructure.
We are in contact with Microsoft Azure and working to resolve the issue and restore service as soon as possible.
Posted Oct 07, 2025 - 16:12 UTC
This incident affected: Ultrafast Grid (UFG), Applitools Eyes, and Autonomous.