Public multi-tenant instance is down

Incident Report for Applitools Status

Resolved

All clouds are now operational with expected performance.
Posted Jul 23, 2026 - 18:36 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 23, 2026 - 18:30 UTC

Monitoring

Azure has deployed mitigation actions that have resolved the multi-tenant public cloud downtime. We are continuing to monitor performance.
Posted Jul 23, 2026 - 18:29 UTC

Update

Azure is investigating networking and traffic-routing anomalies associated with the onset of impact. They are redirecting portions of traffic away from potentially affected network paths.
Posted Jul 23, 2026 - 17:37 UTC

Update

Issue is confirmed to be related to connectivity issues affecting Azure services in West US rgion.
https://azure.status.microsoft/en-us/status
Posted Jul 23, 2026 - 15:58 UTC

Identified

We have identified a potential issue stemming from Azure and are actively working on a mitigation. We will post an update as soon as possible.
Posted Jul 23, 2026 - 15:21 UTC

Update

We are continuing to investigate this issue.
Posted Jul 23, 2026 - 15:02 UTC

Investigating

We are currently investigating an issue that is preventing users from connecting to Eyes and Autonomous on our public cloud (eyes.applitools.com).
Posted Jul 23, 2026 - 15:02 UTC
This incident affected: Applitools Eyes and Autonomous.